2018-09-13から1日間の記事一覧

古いCentOSのcurlで、githubにアクセスしたい時に見るページ

curl --tlsv1.2 https://github.com/hoge.keys --tlsv* オプションで、通信に使用するTSL/SSLのバージョンを指定できる TLS 1.0 は脆弱性があるため、無効になっているサイトが多い(githubとか) しかし、古いバージョンのcurlにはバグがあり、TLS 1.0 でしか…